import re
regex = re.compile(r"^[0\.]+", flags=re.MULTILINE)
test_str = ("0.0.4.1 # 1.\n"
"7.51.4.1 # 2.\n"
"0.1.4.1 # 3.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")