re = /\/\*([\s\S]*)?\*\//
str = '/* This is a comment
/* This is another comment */'
# Print the match result
str.match(re) do |match|
puts match.to_s
end