$re = '/{[^{}]*}/';
$str = '{This is my {sentence|words} I wrote on a {sunny|cold} day.}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);