re = /{[^{}]*}/
str = '{This is my {sentence|words} I wrote on a {sunny|cold} day.}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end