$re = '/(?:^aktuell\/blog|(?!^)\G)\/\K\w+/';
$str = 'aktuell/blog/cat1/cat2/cat3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);