using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:src|href)=[\'""](?!http|https|//)\K/?([^\'""]*)";
string substitution = @"https://airlinercafe.com/$1";
string input = @"<img src=""/"">
<a href=""/contact-us"">Contact Us</a>
<a href=""contact-us"">Contact Us</a>
<img src=""/datas/users/32-img.jpg"" />
<img src=""datas/users/32-img.jpg"" />
<a href=""Https://abs/url/doc.xml"" />RSS</a>
<a href='http://relative/url/'>Note the Single Quote</a>
<img src=""//site.com/protocol-relative-img.jpg"" />
<img https=""https://airlinercafe.com/protocol-relative-img.jpg"" />";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}