re = /(?:src|href)=[\'"](?!http|https|\/\/)\K\/?([^\'"]*)/i
str = '<img src="/">
<a href="/contact-us">Contact Us</a>
<a href="contact-us">Contact Us</a>
<img src="/datas/users/32-img.jpg" />
<img src="datas/users/32-img.jpg" />
<a href="Https://abs/url/doc.xml" />RSS</a>
<a href=\'http://relative/url/\'>Note the Single Quote</a>
<img src="//site.com/protocol-relative-img.jpg" />
<img https="https://airlinercafe.com/protocol-relative-img.jpg" />'
subst = 'https://airlinercafe.com/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result