import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0(?:\\.[0-9]{1,2})?|1(?:\\.00?)?)$";
final String string = "0\n"
+ "0.0\n"
+ "0.00\n"
+ "0.1\n"
+ "0.12\n"
+ "0.34\n"
+ "1\n"
+ "1.0\n"
+ "1.00\n"
+ "0.123\n"
+ "90\n"
+ "3\n"
+ "-1\n"
+ "+1\n"
+ "1.01\n"
+ "1.10\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}