// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0(?:\.[0-9]{1,2})?|1(?:\.00?)?)$").unwrap();
let string = "0
0.0
0.00
0.1
0.12
0.34
1
1.0
1.00
0.123
90
3
-1
+1
1.01
1.10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}