use strict;
my $str = 'โจ feat: add signup pages from (#11)
๐งน feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐งช feat: add signup pages from (#11)
๐ฆ feat: add signup pages from (#11)
โช๏ธ feat: add signup pages from (#11)
โป๏ธ feat: add signup pages from (#11)
๐๏ธ feat: add signup pages from (#11)
';
my $regex = qr/^(?::\w*:|(?:(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])))\s(?<type>\w*)(?:\((?<scope>.*)\))?!?:\s(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s\(?(?<ticket>#\d*)\)?)?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}