import Foundation
let pattern = ##"^(?::\w*:|(?:(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])))\s(?<type>\w*)(?:\((?<scope>.*)\))?!?:\s(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s\(?(?<ticket>#\d*)\)?)?$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
โจ feat: add signup pages from (#11)
๐งน feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐ feat: add signup pages from (#11)
๐งช feat: add signup pages from (#11)
๐ฆ feat: add signup pages from (#11)
โช๏ธ feat: add signup pages from (#11)
โป๏ธ feat: add signup pages from (#11)
๐๏ธ feat: add signup pages from (#11)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}