using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(xxxx)(?<id>\w{4})(?<number>\d{5})";
string input = @"xxxxcn0700814";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}