$re = '/(xxxx)(?<id>\w{4})(?<number>\d{5})/';
$str = 'xxxxcn0700814';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);