#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<a.*?href=".*?//.*?">.*?</a>)"
Local $sString = "dqwqwfqfewf fwefwef fwe fw fwefwefwe" & @CRLF & _
"fwefwefwefwefwefwefwefwef fwef." & @CRLF & _
"<a href="/dwdw.php/">dwdqwdqwd</a>" & @CRLF & _
"fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew." & @CRLF & _
"<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>" & @CRLF & _
"dqwqwfqfewf fwefwef fwe fw fwefwefwe" & @CRLF & _
"<a href="fdwdwdwd//dwdw.php">dwdqwdqwd</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")