$re = '~(<a.*?href=".*?//.*?">.*?</a>)~';
$str = 'dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="fdwdwdwd//dwdw.php">dwdqwdqwd</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);