import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td align=\\\"left\\\">\\s*(<a href=\\\"http:\\/\\/www.proxynova.com\\/proxy-server-list\\/port-\\d+|\\d+).*?\\s*<\\/td>";
final String string = "<table width=\"950\" class=\"table\" id=\"tbl_proxy_list\">\n"
+ "<thead>\n"
+ " <tr>\n"
+ " <th>Proxy IP</th>\n"
+ " <th>Proxy Port</th>\n"
+ " <th>Last Check</th>\n"
+ " <th nowrap=\"nowrap\"><span title=\"Proxy Speed in bytes per second\">Proxy Speed</span></th>\n"
+ " <th>Uptime</th>\n"
+ " <th><span title=\"The location of that particular proxy.\">Proxy Country</span></th>\n"
+ " <th>Anonymity </th>\n"
+ " </tr>\n"
+ "</thead>\n"
+ "<tbody>\n"
+ " <tr>\n"
+ " <td align=\"left\"> \n"
+ " <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
+ " </td>\n\n"
+ " <td align=\"left\">\n"
+ " <a href=\"http://www.proxynova.com/proxy-server-list/port-8080\">8080</a>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
+ " </td> \n"
+ " <td align=\"left\">\n"
+ " <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
+ " </td>\n"
+ " <td style=\"text-align:center !important;\">\n"
+ " <span style=\"color:#009900;\">59%</span>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
+ " <a href=\"/proxy-server-list/country-in/\">India \n"
+ " <span class=\"proxy-city\"> - Chandannagar </span> \n"
+ " </a>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td align=\"left\"> \n"
+ " <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
+ " </td>\n\n"
+ " <td align=\"left\">\n"
+ " <a href=\"http://www.proxynova.com/proxy-server-list/port-8080\">8080</a>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
+ " </td> \n"
+ " <td align=\"left\">\n"
+ " <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
+ " </td>\n"
+ " <td style=\"text-align:center !important;\">\n"
+ " <span style=\"color:#009900;\">59%</span>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
+ " <a href=\"/proxy-server-list/country-in/\">India \n"
+ " <span class=\"proxy-city\"> - Chandannagar </span> \n"
+ " </a>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td align=\"left\"> \n"
+ " <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
+ " </td>\n\n"
+ " <td align=\"left\">\n"
+ " 80\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
+ " </td> \n"
+ " <td align=\"left\">\n"
+ " <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
+ " </td>\n"
+ " <td style=\"text-align:center !important;\">\n"
+ " <span style=\"color:#009900;\">59%</span>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
+ " <a href=\"/proxy-server-list/country-in/\">India \n"
+ " <span class=\"proxy-city\"> - Chandannagar </span> \n"
+ " </a>\n"
+ " </td>\n"
+ " <td align=\"left\">\n"
+ " <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ "</tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}