# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td align=\"left\">\s*(<a href=\"http:\/\/www.proxynova.com\/proxy-server-list\/port-\d+|\d+).*?\s*<\/td>"
test_str = ("<table width=\"950\" class=\"table\" id=\"tbl_proxy_list\">\n"
"<thead>\n"
" <tr>\n"
" <th>Proxy IP</th>\n"
" <th>Proxy Port</th>\n"
" <th>Last Check</th>\n"
" <th nowrap=\"nowrap\"><span title=\"Proxy Speed in bytes per second\">Proxy Speed</span></th>\n"
" <th>Uptime</th>\n"
" <th><span title=\"The location of that particular proxy.\">Proxy Country</span></th>\n"
" <th>Anonymity </th>\n"
" </tr>\n"
"</thead>\n"
"<tbody>\n"
" <tr>\n"
" <td align=\"left\"> \n"
" <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
" </td>\n\n"
" <td align=\"left\">\n"
" <a href=\"http://www.proxynova.com/proxy-server-list/port-8080\">8080</a>\n"
" </td>\n"
" <td align=\"left\">\n"
" <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
" </td> \n"
" <td align=\"left\">\n"
" <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
" </td>\n"
" <td style=\"text-align:center !important;\">\n"
" <span style=\"color:#009900;\">59%</span>\n"
" </td>\n"
" <td align=\"left\">\n"
" <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
" <a href=\"/proxy-server-list/country-in/\">India \n"
" <span class=\"proxy-city\"> - Chandannagar </span> \n"
" </a>\n"
" </td>\n"
" <td align=\"left\">\n"
" <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
" </td>\n"
" </tr>\n"
" <tr>\n"
" <td align=\"left\"> \n"
" <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
" </td>\n\n"
" <td align=\"left\">\n"
" <a href=\"http://www.proxynova.com/proxy-server-list/port-8080\">8080</a>\n"
" </td>\n"
" <td align=\"left\">\n"
" <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
" </td> \n"
" <td align=\"left\">\n"
" <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
" </td>\n"
" <td style=\"text-align:center !important;\">\n"
" <span style=\"color:#009900;\">59%</span>\n"
" </td>\n"
" <td align=\"left\">\n"
" <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
" <a href=\"/proxy-server-list/country-in/\">India \n"
" <span class=\"proxy-city\"> - Chandannagar </span> \n"
" </a>\n"
" </td>\n"
" <td align=\"left\">\n"
" <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
" </td>\n"
" </tr>\n"
" <tr>\n"
" <td align=\"left\"> \n"
" <span class=\"row_proxy_ip\">220.225.87.129</span>\n"
" </td>\n\n"
" <td align=\"left\">\n"
" 80\n"
" </td>\n"
" <td align=\"left\">\n"
" <time class=\"icon icon-check timeago\" datetime=\"2016-03-14 12:58:53Z\"></time>\n"
" </td> \n"
" <td align=\"left\">\n"
" <div class=\"progress-bar\" data-value=\"7.7100404\" title=\"5855.0202\"></div>\n"
" </td>\n"
" <td style=\"text-align:center !important;\">\n"
" <span style=\"color:#009900;\">59%</span>\n"
" </td>\n"
" <td align=\"left\">\n"
" <img src=\"//www.proxynova.com/assets/images/blank.gif\" class=\"flag flag-in\" width=\"15\" height=\"11\" alt=\"IN\" />\n"
" <a href=\"/proxy-server-list/country-in/\">India \n"
" <span class=\"proxy-city\"> - Chandannagar </span> \n"
" </a>\n"
" </td>\n"
" <td align=\"left\">\n"
" <span class=\"proxy_transparent\" style=\"font-weight:bold; font-size:10px;\">Transparent</span>\n"
" </td>\n"
" </tr>\n"
"</tbody>\n"
"</table>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.