using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]*,){6}([^,]*)";
string input = @"547-18-5874,519480195,AE09430101,160, ,fre fdds,0065.00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}