const regex = /((.*>.*)|(.*(On).*(wrote:)$)|(.*(Date):.*(\+\d\d\d\d)?$)|(.*(From):.*(\.com)?(\]|>)?$))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((.*>.*)|(.*(On).*(wrote:)$)|(.*(Date):.*(\\+\\d\\d\\d\\d)?$)|(.*(From):.*(\\.com)?(\\]|>)?$))', '')
const str = `abc From: blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}