re = /((.*>.*)|(.*(On).*(wrote:)$)|(.*(Date):.*(\+\d\d\d\d)?$)|(.*(From):.*(\.com)?(\]|>)?$))/
str = 'abc From: blah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end