import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\s{4}|\\t)*(?:[^a]t|a[^t]|at[^\\s]+)|[^\\s]+).*";
final String string = "---------- snippet start ----------\n"
+ "JUnit version 4.11\n"
+ "I.E\n"
+ "Time: 0.015\n"
+ "There was 1 failure:\n"
+ "1) testPerson(PersonTest)\n"
+ "org.junit.ComparisonFailure: expected:<John[1]> but was:<John[]>\n"
+ " a t org.junit.Assert.assertEquals(Assert.java:115)\n"
+ " attention org.junit.Assert.assertEquals(Assert.java:144)\n"
+ " at PersonTest.testPerson(PersonTest.java:21)\n"
+ " at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\n"
+ " at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)\n"
+ " at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)\n"
+ " at java.lang.reflect.Method.invoke(Unknown Source)\n"
+ " at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)\n\n"
+ "---------- snippet end----------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}