# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:\s{4}|\t)*(?:[^a]t|a[^t]|at[^\s]+)|[^\s]+).*"
test_str = ("---------- snippet start ----------\n"
"JUnit version 4.11\n"
"I.E\n"
"Time: 0.015\n"
"There was 1 failure:\n"
"1) testPerson(PersonTest)\n"
"org.junit.ComparisonFailure: expected:<John[1]> but was:<John[]>\n"
" a t org.junit.Assert.assertEquals(Assert.java:115)\n"
" attention org.junit.Assert.assertEquals(Assert.java:144)\n"
" at PersonTest.testPerson(PersonTest.java:21)\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)\n"
" at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)\n"
" at java.lang.reflect.Method.invoke(Unknown Source)\n"
" at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)\n\n"
"---------- snippet end----------")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.