const regex = new RegExp('\\b(?:https?://)?(www\\.[^.\\s]+\\.[^/\\s]+|\\d+\\.\\d+\\.\\d+\\.\\d+)', 'g')
const str = `http://www.google.com
www.google.com
www.google
google.com
http://google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}