re = /\b(?:https?:\/\/)?(www\.[^.\s]+\.[^\/\s]+|\d+\.\d+\.\d+\.\d+)/
str = 'http://www.google.com
www.google.com
www.google
google.com
http://google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end