#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.{3})^(?:a?b?c?)$"
Local $sString = "abc" & @CRLF & _
"bca" & @CRLF & _
"cab" & @CRLF & _
"ab" & @CRLF & _
"ac" & @CRLF & _
"bc" & @CRLF & _
"ba" & @CRLF & _
"ca" & @CRLF & _
"cb" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")