$re = '/(?!.{3})^(?:a?b?c?)$/m';
$str = 'abc
bca
cab
ab
ac
bc
ba
ca
cb
a
b
c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);