$re = '/:\/\/[^\\\\]+\/(?<name>[^-]+)-/';
$str = 'http://claim-esb-sys.test.xxx.com/abc-3.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);