re = /:\/\/[^\\]+\/(?<name>[^-]+)-/
str = 'http://claim-esb-sys.test.xxx.com/abc-3.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end