using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jdbc:postgresql:(?=.)(?:(?:/$)|//(?:(?<user>[^:\n\r]+)(?::(?<pass>[^@\n\r]+))@)?(?<host>[^:/\r\n]+)(?::(?<port>\d+))?/)?(?<db>.+)?";
string input = @"jdbc:postgresql:database
jdbc:postgresql:/
jdbc:postgresql://host/database
jdbc:postgresql://user:password@host/database
jdbc:postgresql://host/
jdbc:postgresql://host:1234/database
jdbc:postgresql://host:1234/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}