const regex = new RegExp('jdbc:postgresql:(?=.)(?:(?:/$)|//(?:(?<user>[^:\\n\\r]+)(?::(?<pass>[^@\\n\\r]+))@)?(?<host>[^:/\\r\\n]+)(?::(?<port>\\d+))?/)?(?<db>.+)?', 'gm')
const str = `jdbc:postgresql:database
jdbc:postgresql:/
jdbc:postgresql://host/database
jdbc:postgresql://user:password@host/database
jdbc:postgresql://host/
jdbc:postgresql://host:1234/database
jdbc:postgresql://host:1234/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}