$re = '/^(\w+)\s*=\s*([^#\n]+?)\s*(?=#|$)/m';
$str = 'param_1 = test with comment # comment
param_1 = test without comment
param_1=test without comment
param_1=test with comment # comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);