re = /^(\w+)\s*=\s*([^#\n]+?)\s*(?=#|$)/m
str = 'param_1 = test with comment # comment
param_1 = test without comment
param_1=test without comment
param_1=test with comment # comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end