package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"(?<field1>[^?]+)`)
var str = `"Get \search\ip\6789\?=number\90"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}