$re = '/\"(?<field1>[^?]+)/m';
$str = '"Get \\search\\ip\\6789\\?=number\\90"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);