const regex = /\[url=mailto:([^\?\]]*).*?\[\/url\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[url=mailto:([^\\?\\]]*).*?\\[\\\/url\\]', 'gm')
const str = `[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}