$re = '/\[url=mailto:([^\?\]]*).*?\[\/url\]/m';
$str = '[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]
[url=mailto:service@paypal.com.au]service@paypal.com.au[/url]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);