import re
regex = re.compile(r"(?<operator>[+\-])?(?:(?<dice>(?<numberOfDice>[\d]+)?[dD](?<faces>[\d]+)(?<explode>![\d]*)?(?<implode>¡[\d]*)?(?<selective>[kd][\d]+)?)|(?<constant>[\d]+))", flags=re.MULTILINE)
test_str = ("d4\n"
"1d4\n"
"1d20-10\n"
"2d6+1d8\n"
"3d10k2\n"
"3d10d2\n"
"6d6!\n"
"6d6!5\n"
"d100!96¡5\n"
"d6¡\n"
"d20¡2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")