#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^'"\s.]+\.[^\s'"&]+&[^\s"']+(?!\S)"
Local $sString = "www.google.com/mom=3&f" & @CRLF & _
" -H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\" & @CRLF & _
"-H "Content-Type: google.com/cool?mom=3&f" \\" & @CRLF & _
"www.google.com/mom=3&fbom=cbom'" & @CRLF & _
""www.google.com/mom=3&f"" & @CRLF & _
"curl -X GET \\" & @CRLF & _
" -H "User-Agent: Dalvik/2.1.0 (Linux; U; Android 10; SM-A705FN Build/QP1A.190711.020) Test/4.6.4.459" \\" & @CRLF & _
" -H "Authorization: bearer XXX" \\" & @CRLF & _
" -H "x-storefront-id: 1" \\" & @CRLF & _
" -H "x-application-id: 5" \\" & @CRLF & _
" -H "Build: 4.6.4.459" \\" & @CRLF & _
" -H "Platform: Android" \\" & @CRLF & _
" -H "Gender: M" \\" & @CRLF & _
" -H "SearchSegment: 98" \\" & @CRLF & _
" -H "OSVersion: 10" \\" & @CRLF & _
" -H "DeviceId: b147ee89" \\" & @CRLF & _
" -H "pid: bdb5748e" \\" & @CRLF & _
" -H "sid: 5096fd6e" \\" & @CRLF & _
" -H "x-features: FEATURE1_ENABLED" \\" & @CRLF & _
" -H "Accept-Language: tr-TR" \\" & @CRLF & _
" -H "Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no" \\" & @CRLF & _
" google.com/cool?cool1=yes&cool2=no&cool3=no`" & @CRLF & _
"" & @CRLF & _
"/^((?!hede).)*$/s" & @CRLF & _
"^(?:(?!:hede).)*$" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")