import re
regex = re.compile(r"[^'\"\s.]+\.[^\s'\"&]+&[^\s\"']+(?!\S)")
test_str = ("www.google.com/mom=3&f\n"
" -H \"Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no\" \\\\\n"
"-H \"Content-Type: google.com/cool?mom=3&f\" \\\\\n"
"www.google.com/mom=3&fbom=cbom'\n"
"\"www.google.com/mom=3&f\"\n"
"curl -X GET \\\\\n"
" -H \"User-Agent: Dalvik/2.1.0 (Linux; U; Android 10; SM-A705FN Build/QP1A.190711.020) Test/4.6.4.459\" \\\\\n"
" -H \"Authorization: bearer XXX\" \\\\\n"
" -H \"x-storefront-id: 1\" \\\\\n"
" -H \"x-application-id: 5\" \\\\\n"
" -H \"Build: 4.6.4.459\" \\\\\n"
" -H \"Platform: Android\" \\\\\n"
" -H \"Gender: M\" \\\\\n"
" -H \"SearchSegment: 98\" \\\\\n"
" -H \"OSVersion: 10\" \\\\\n"
" -H \"DeviceId: b147ee89\" \\\\\n"
" -H \"pid: bdb5748e\" \\\\\n"
" -H \"sid: 5096fd6e\" \\\\\n"
" -H \"x-features: FEATURE1_ENABLED\" \\\\\n"
" -H \"Accept-Language: tr-TR\" \\\\\n"
" -H \"Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no\" \\\\\n"
" google.com/cool?cool1=yes&cool2=no&cool3=no`\n\n"
"/^((?!hede).)*$/s\n"
"^(?:(?!:hede).)*$\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")