const regex = new RegExp('.*?\\bwhite\\b\\s+\\bbear\\b.*', 'gi')
const str = `White bear
Brown Bear
Brown Bear 100 Kg
White bear 200 cm
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}