$re = '/.*?\bwhite\b\s+\bbear\b.*/i';
$str = 'White bear
Brown Bear
Brown Bear 100 Kg
White bear 200 cm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);