package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{\d+={\d+=(.*?)=\d+},\s+\d+={\d+=(.*?)=\d+}}`)
var str = `{8={3=4,6=7}, 9={2=5,6=10}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}