$re = '/{\d+={\d+=(.*?)=\d+},\s+\d+={\d+=(.*?)=\d+}}/';
$str = '{8={3=4,6=7}, 9={2=5,6=10}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);