const regex = /(.)(?=.*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)(?=.*\\1)', 'gm')
const str = `111aabbccxccybbzaa1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);