$re = '/(.)(?=.*\1)/m';
$str = '111aabbccxccybbzaa1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;