#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=X)[0-9\.]+(?= )"
Local $sString = "N9 G00 X2675.766 Y427.409 Z730" & @CRLF & _
"N11 G00 X2675.766 Y427.409" & @CRLF & _
"N13 G00 X2675.766 Y427.409" & @CRLF & _
"N15 G00 X2675.766 Y427.409 Z505" & @CRLF & _
"N17 F4000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")