import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=X)[0-9\\.]+(?= )";
final String string = "N9 G00 X2675.766 Y427.409 Z730\n"
+ "N11 G00 X2675.766 Y427.409\n"
+ "N13 G00 X2675.766 Y427.409\n"
+ "N15 G00 X2675.766 Y427.409 Z505\n"
+ "N17 F4000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}