import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*MVP[^\\\\]*$)(?!.*Missing[^\\\\]*$).*\\.(?:csv|xlsx?|txt)$";
final String string = "\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProvEntityFix1016.xlsx\n"
+ "\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_EntityFix1016.xlsx\n"
+ "\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_Entity_MissingFix1016.xlsx\n"
+ "\\\\p8files\\MVP\\Inbound\\Missing2023\\202310\\20231016\\BillingProv_MVP_Entity_Fix1016.xlsx\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}