$re = '/^(?=.*MVP[^\\\\]*$)(?!.*Missing[^\\\\]*$).*\.(?:csv|xlsx?|txt)$/m';
$str = '\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProvEntityFix1016.xlsx
\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_EntityFix1016.xlsx
\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_Entity_MissingFix1016.xlsx
\\\\p8files\\MVP\\Inbound\\Missing2023\\202310\\20231016\\BillingProv_MVP_Entity_Fix1016.xlsx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);