#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^(?:(?:\d+|[A-Z])\.?)?)\t"
Local $sString = " text" & @CRLF & _
"1. text" & @CRLF & _
"1 text" & @CRLF & _
"A. text" & @CRLF & _
"text text" & @CRLF & _
"" & @CRLF & _
"That is, it shouldn't match tabs that are" & @CRLF & _
" at the beginning of the text," & @CRLF & _
" after a listed item mark [A-Z] or [0-9]. Here is my expression:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")